Привязка конфигурации к диску


Простой способ определить по id HDD, используют ли твою работу на постороннем компьютере

//Модуль приложения который можно запоролить или не включать в поставку

Процедура ПриНачалеРаботыСистемы()
ПодключитьОбработчикОжидания("ЗащитаОтДурака",60,Истина) ;

КонецПроцедуры()

Процедура ЗащитаОтДурака() экспорт
// Создаем объект FileSystemObject
FSO = Новый COMОбъект("Scripting.FileSystemObject");
// Получаем ссылку на объект
Drive = FSO.GetDrive("C") ;
//в конфу предварительно добавляем константу НомерС
Если константы.НомерС.Получить() <> Строка(Drive.SerialNumber) тогда
Предупреждение("Вы используете более одной копии программы! Обратитесь к разработчику");
ЗавершитьРаботуСистемы(Ложь);
Иначе
КонецЕсли
КонецПроцедуры; 

Для клиентов которые заплатили, устанавливаем номер константы обработкой ЗащитаОтДурака.epf в первые 60 секунд работы системы и работаем)

Файлы обработки:

-



Back to top