Прикол над пользователями. 1 апреля


Завтра первое апреля. День смеха)) Разбавление обычных будней.
При открытии формы раскрашивает цветами радуги табличную часть.

 

 

При открытии формы раскрашивает цветами радуги табличную часть.
Выглядит очень  симпатично.

Реализовано в глобальном модуле:

Раскрашивать можно табличные части, таблицы значений и списки (справочников, документов и т.д.)

Перем глМассивЦветов; // 01.04.2011

Перем глГСЧ; // 01.04.2011


#Если Клиент Тогда
Функция РаскраситьСтрокиРадиШутки() Экспорт // 01.04.2011

    
Если Формат(ТекущаяДата(), "ДФ=ddMM")="0104" Тогда
        Возврат Ложь;
    КонецЕсли;

    Если 
глГСЧ.СлучайноеЧисло(0, 100)>13 Тогда
        Возврат Ложь;
    КонецЕсли;

    Возврат Истина;

КонецФункции

Процедура 
РаскраситьТЧ(Элемент, ОформленияСтрок) Экспорт  // 01.04.2011
    
Попытка

        
Сч = 0;
        
макс = глМассивЦветов.Количество();
        
ЭтоТЗ = ТипЗнч(Элемент.Значение)=Тип("ТаблицаЗначений") Или Найти(ТипЗнч(Элемент.Значение), "табличная часть")>0;

        Для Каждого 
Оформление Из ОформленияСтрок Цикл

            Если 
ЭтоТЗ Тогда
                
Оформление.ЦветФона = глМассивЦветов[ Элемент.Значение.Индекс(Оформление.ДанныеСтроки) % макс];
            Иначе
                
Оформление.ЦветФона = глМассивЦветов[ Сч % макс ];
                
Сч = Сч+1;
            КонецЕсли;

        КонецЦикла;

    Исключение
    КонецПопытки;
КонецПроцедуры
#КонецЕсли

глГСЧ = Новый ГенераторСлучайныхЧисел;
глМассивЦветов = Новый Массив;
глМассивЦветов.Добавить(Новый Цвет(255, 255, 255));
глМассивЦветов.Добавить(Новый Цвет(254, 251, 251));
глМассивЦветов.Добавить(Новый Цвет(254, 192, 192));
глМассивЦветов.Добавить(Новый Цвет(254, 106, 106));
глМассивЦветов.Добавить(Новый Цвет(254, 68, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 84, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 116, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 164, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 215, 62));
глМассивЦветов.Добавить(Новый Цвет(249, 249, 64));
глМассивЦветов.Добавить(Новый Цвет(165, 234, 74));
глМассивЦветов.Добавить(Новый Цвет(99, 207, 86));
глМассивЦветов.Добавить(Новый Цвет(62, 230, 200));
глМассивЦветов.Добавить(Новый Цвет(62, 237, 254));
глМассивЦветов.Добавить(Новый Цвет(62, 181, 232));
глМассивЦветов.Добавить(Новый Цвет(62, 109, 190));
глМассивЦветов.Добавить(Новый Цвет(160, 62, 185));
глМассивЦветов.Добавить(Новый Цвет(254, 95, 219));
глМассивЦветов.Добавить(Новый Цвет(254, 207, 243));

Для раскраски нужно приписать событие в обработчик ПриПолученииДанных:

Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

    
РаскраситьТЧ(Элемент, ОформленияСтрок); //01.04.2011

КонецПроцедуры

 

 

 

 

Файлы обработки:

-



Back to top