Проверка наличия подписки ИТС по регистрационному номеру поставки


Быстро, на коленке написал проверку наличия подписки ИТС по регистрационному номеру поставки через сайт 1С. Может быть изобрел велосипед, но готового решения не нашел.


Собственно код:

Функция РазборСтроки(знач Стр, Разделитель) Экспорт

МассивЗначений = Новый Массив;

Символ = Найти(Стр, Разделитель);
Пока Символ > 0 Цикл

МассивЗначений.Добавить(Лев(Стр, Символ - 1));
Стр = Прав(Стр, СтрДлина(Стр) - Символ);

Символ = Найти(Стр, Разделитель);
КонецЦикла;
МассивЗначений.Добавить(Стр);

Возврат МассивЗначений;
КонецФункции

Функция ПроверитьПодпискуИТС(НомерДляПроверкиРегистрации)
URL = "1c.ru";

URLПроверки = "/rus/support/its/js-check-subscribe.jsp?rn="+НомерДляПроверкиРегистрации;
Коннект = Новый HTTPСоединение(URL);
ЧтениеТекста = Новый ТекстовыйДокумент;

СтруктураПараметров = Новый Структура;

ИмяВременногоФайла=ПолучитьИмяВременногоФайла("txt");
Коннект.Получить(URLПроверки,ИмяВременногоФайла);

ЧтениеТекста.Прочитать(ИмяВременногоФайла);
Для НомерСтроки=1 по ЧтениеТекста.КоличествоСтрок() Цикл

Стр = ЧтениеТекста.ПолучитьСтроку(НомерСтроки);
Если Найти(Стр,"ajaxCheck")>0 Тогда

Стр = СтрЗаменить(Стр,"ajaxCheck","");
Стр = СтрЗаменить(Стр,"(","");

Стр = СтрЗаменить(Стр,")","");
МассивСтроки = РазборСтроки(Стр,",");

СтруктураПараметров.Вставить("РегНомер",МассивСтроки[0]);
СтруктураПараметров.Вставить("ПодпискаАктивна",МассивСтроки[1]);

СтруктураПараметров.Вставить("ТребуетсяПодписка",МассивСтроки[2]);
КонецЕсли;
КонецЦикла;

Возврат СтруктураПараметров;
КонецФункции

Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)

ДанныеОПодписке = ПроверитьПодпискуИТС("1234567");

Сообщить(ДанныеОПодписке.РегНомер);
Сообщить(ДанныеОПодписке.ПодпискаАктивна);

Сообщить(ДанныеОПодписке.ТребуетсяПодписка);


КонецПроцедуры

Как и обещал, выкладываю обработку.

Файлы обработки:

-



Back to top