Завершение работы пользователей


!Обновление от 12.03.2012!. Следующая версия обработки завершения работы пользователей. Обработка находится в alpha тестировании. На данный момент работает обычная форма. Управляемая форма создана, но на ней нет функционала. Обработку так же можно запускать как внешнюю, с ограниченным функционалом (описание см ниже). Решил выложить обработку, дабы не забросить проект, т.к. текущая работа забирает фактически все время, а определенные наработки по 2 версии уже есть. Буду рад тесту, любым комментариям и помощи. По мере выявления ошибок буду стараться их исправлять.

Версия 12.03.2012

В новой версии учтены пожелания, указанные в предыдущей версии, переработан интерфейс. 

 

Основные возможности обработки:

  1. просматривать список активных пользователей (список отключенных пользователей);
  2. устанавливать действия не активным пользователям (к примеру сообщение при входе)
  3. быстрое отключением пользователей в два нажатия
  4. выбор шаблонов сообщений (если справочник есть в конфигурации)
  5. создание гибких шаблонов завершения работы
  6. сохранение настроек
  7. возможность использования как внешней обработки (с ограниченными возможностями)
  8. задавать кто не будет отключен для сервисной работы;
  9. установка монопольного режима (автоматическая установка монопольного режима при выходе всех пользователей)
  10. выдержка времени не подключения;
  11. запрет подключения к базе в течении определенного времени;
  12. отправка сообщений пользователям (3 вида отправки)
  13. гибкое оповещение о необходимости выхода
  14. запрет работы пользователей пока конфигурация не совпадает с конфигурацией БД
  15. не ограниченное количество режим заврешения работы с возможностью написания вставок кода
  16. отображение информации о пользователях, которые ограничены в подключении к ИБ, а так же оставшееся время ограничения
  17. гибкая система разрешения входа в ИБ
  18. возможность быстрого продления ограничения доступа на 5 или 10 - 15 минут

Если конфигурацию не хочется дорабатывать то данную обработку можно запускать как внешнюю. При внешнем запуске обработка использует стандартный механизм блокировки пользователей. Для удобства использования на форму добавлена галочка "Дописать новый код разрешения в параметры запуска". Если данныя галочка установлена, то при установке  блокировки код доступа будет дописан в параметры запуска текущей ИБ с сохранением уже установленных параметров запуска.

 

В случае доработки конфигурации

1. необходимы объекты есть в cf файле, который сделан на базе пустой конфигурации

список необхоимых объектов:

  1.1 Справочники   

    - ШаблоныСообщенийЗавершения    
    - ШаблоныЗавершенияРаботы    
    - ВариантыЗавершенияРаботы    

  1.2 Обработка    

    - ЗавершениеРаботыПользователейEX2    

  1.3 Регистр сведений

    - ОтключениеПользователейEX    

  1.4 Перечисление  

    - ДействияСПользователямиEX

  1.5 Модуль обычного приложения

Процедура ПередНачаломРаботыСистемы(Отказ)
    //какой то код
    СтартПроверкиОтключения(Отказ);
КонецПроцедуры


Процедура
ПриЗавершенииРаботыСистемы()
    //какой то код
    СтопПроверкиОтключения();
КонецПроцедуры

 1.6 Общий модуль

   - ОтключениеПользователейEX2

 

2. необходимо заполнить справочник "Варианты завершения работы"

При необходимости можно добавить свои варианты завершения, с необходимым кодом. 

Справочник пользователей заменять не нужно, он был добавлен чтобы были правильные ссылки в пустой конфигурации!

 

Версия 06.09.2011 

Пояснения по начальному встраиванию в конфигурацию можно так же смотреть тут http://store-1c.blogspot.com/2011/03/1_27.html (если что то не получается Smile)

Основные возможности обработки:

  1. просматривать список активных пользователей;
  2. задавать кто не будет отключен для сервисной работы;
  3. возможность быстрого отключения;
  4. установка монопольного режима;
  5. выдержка времени не подключения;
  6. запрет подключения к базе в течении определенного времени;
  7. отключение не всех пользователей.
  8. отправка сообщений пользователям
  9. гибкое оповещение о необходимости выхода
  10. 4 режима завершения
    1. Запрет дальнейшего подключения по установленному времени и отключение пользователей от ИБ
    2. Завершение работы пользователей, с возможностью дальнейшего подключения к ИБ
    3. Перезапуск сессии пользователя(ей) ИБ
    4. Завершение работы ИБ с подтверждением пользователя(ей)
  11. отображение информации о пользователях, которые ограничены в подключении к ИБ, а так же оставшееся время ограничения
  12. гибкая система разрешения входа в ИБ
  13. возможность быстрого продления ограничения доступа на 5 или 10 мину

 

Доработка конфигурации:

  • Обработка настройки отключения (в приложении)
  • Регистр сведений
  • Общий модуль
  • Модуль приложения

Обращаю внимание на то что:

Для УПП, КА, УТ, БП необходимо изменить следующий код во всех модулях обработки 
ТекПользователь = УправлениеПользователями.ОпределитьТекущегоПользователя(); 
на следующий: 
ТекПользователь = глЗначениеПеременной("глТекущийПользователь");

 

Регистр сведений

доОтключениеПользователей, непереодический, с независимым режимом записи.

Измерения:

Пользователь - справочник пользователи, ведущее или основной отбор

Ресурсы:

  • Отключить - Булево;
  • ЗапретПодключения - Булево;
  • БыстроеОтключение - Булево;
  • СостояниеОтключения - Строка, 30 символов, переменная;
  • Сообщение - Строка, 300 символов, переменная;
  • ДатаВремяПуска - Дата, Дата и время;
  • ОтключениеМинут - Число, 2 разряда; 
  • ПаузаДоОтключения - Число, 3 разряда, точность 2. 
  • ДействиеОтключения - Строка, 30 символов, переменная; 
  • ОбменСообщений - Строка, 255 символов

Общий модуль "доОтключениеПользователей"

Функция ИзСекундВчасы(Секунд = 0)

    Часов = Цел(Секунд/3600);
   
СекОстМин = Секунд%3600;
   
Минут = Цел(СекОстМин/60);
   
Сек = СекОстМин%60;
    Если
Часов < 10 Тогда
       
Часов = "0" + СокрЛП(Часов);
    Иначе
       
Часов = СокрЛП(Часов);
    КонецЕсли;
    Если
Минут < 10 Тогда
       
Минут = "0" + СокрЛП(Минут);
    Иначе
       
Минут = СокрЛП(Минут);
    КонецЕсли;
    Если
Сек < 10 Тогда
       
Сек = "0" + СокрЛП(Сек);
    Иначе
       
Сек = СокрЛП(Сек);
    КонецЕсли;
    Возврат
Часов + ":" + Минут + ":" + Сек;

КонецФункции

// Процедура контроля возможности подключения.
//
Процедура СтартПроверкиОтключения(Отказ) Экспорт
   
Пользователь = УправлениеПользователями.ОпределитьТекущегоПользователя();
   
Зп = Новый Запрос;
   
Зп.УстановитьПараметр("Пользователь",Пользователь);
   
Зп.Текст = "ВЫБРАТЬ
               |    доОтключениеПользователей.Пользователь,
               |    доОтключениеПользователей.ЗапретПодключения,
               |    доОтключениеПользователей.ДатаВремяПуска,
               |    доОтключениеПользователей.ОтключениеМинут,
               |    доОтключениеПользователей.ПаузаДоОтключения,
               |    доОтключениеПользователей.ОбменСообщений
               |ИЗ
               |    РегистрСведений.доОтключениеПользователей КАК доОтключениеПользователей
               |ГДЕ
               |    доОтключениеПользователей.Пользователь = &Пользователь"
;
   
РезультатЗп = Зп.Выполнить().Выбрать();
    Если
РезультатЗп.Следующий() Тогда
        Если
РезультатЗп.ЗапретПодключения Тогда
           
НеПодключать = Ложь;
           
// Расчет времени не подключения
           
ТекДата = ТекущаяДата();
           
СтартДата = РезультатЗп.ДатаВремяПуска;
           
ВремяПаузы = РезультатЗп.ОтключениеМинут * 60 + РезультатЗп.ПаузаДоОтключения * 15;
           
ДельтаПаузы = ТекДата - СтартДата;
            Если
ВремяПаузы > ДельтаПаузы Тогда
               
НеПодключать = Истина;
            КонецЕсли;
           
// Конец Расчета времени не подключения
           
Если НеПодключать Тогда
               
#Если Клиент Тогда
                   
Если РезультатЗп.ОбменСообщений <> "" Тогда
                       
ТекДата = ТекущаяДата();
                       
СтартДата = РезультатЗп.ДатаВремяПуска;
                       
ВремяПаузы = РезультатЗп.ОтключениеМинут * 60 + РезультатЗп.ПаузаДоОтключения * 60;
                       
ДельтаПаузы = ТекДата - СтартДата;
                       
ПредполагаемоеВремя = ИзСекундВЧасы(ВремяПаузы - ДельтаПаузы);
                       
ПредВремя = ТекДата + (ВремяПаузы - ДельтаПаузы);
                        Если
Найти(РезультатЗп.ОбменСообщений, "#sys") > 0 Тогда
                           
ОчищенноеСообщение = Сред(РезультатЗп.ОбменСообщений, 5, СтрДлина(РезультатЗп.ОбменСообщений) - 4);
                           
Предупреждение("Подключение запрещено. Ведутся сервисные работы. " + ОчищенноеСообщение + Символы.ПС + "Предполагаемое время разрешения входа в базу: " + Строка(ПредВремя) + " (через " + Строка(ПредполагаемоеВремя) + ")", 20, "Подключение...");
                        Иначе
                           
Предупреждение("Подключение запрещено. Ведутся сервисные работы. " + РезультатЗп.ОбменСообщений  + Символы.ПС + "Предполагаемое время разрешения входа в базу: " + Строка(ПредВремя) + " (через " + Строка(ПредполагаемоеВремя) + ")", 20, "Подключение...");
                        КонецЕсли;
                    Иначе
                       
Предупреждение("Подключение запрещено. Ведутся сервисные работы."  + Символы.ПС + "Предполагаемое время разрешения входа в базу: " + Строка(ПредВремя) + " (через " + Строка(ПредполагаемоеВремя) + ")", 5, "Подключение...");
                    КонецЕсли;
               
#КонецЕсли
               
Отказ = Истина;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
   
// Проверка и опрос состояния отключения
   
ПодключитьОбработчикОжидания("ЦиклическийВызов",15);
КонецПроцедуры
// СтартПроверкиОтключения()

// Процедура контроля отключения. Конечный автомат состояний отключения.
//
Процедура ЦиклическийВызов() Экспорт
   
ОтклПользователей = РегистрыСведений.доОтключениеПользователей;
   
Отбор = Новый Структура("Пользователь");
   
Отбор.Пользователь = УправлениеПользователями.ОпределитьТекущегоПользователя();
   
ВыборкаРегистра = ОтклПользователей.Выбрать(Отбор);
    Пока
ВыборкаРегистра.Следующий() Цикл
       
Запись = ВыборкаРегистра.ПолучитьМенеджерЗаписи();
       
Запись.Прочитать();
       
СостояниеОткл = СокрЛП(Запись.СостояниеОтключения);
       
ДействиеОткл = СокрЛП(Запись.ДействиеОтключения);
       
ВремяОткл = Запись.ПаузаДоОтключения;

       
//---------------------------------------
       
Если СостояниеОткл = "Запрет подключения" Тогда
           
ДействиеЗавершения = "Запрет подключения";
           
СостОткл = "Ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли
       
ИначеЕсли СостояниеОткл = "Запрет подключения +" Тогда
           
ДействиеЗавершения = "Запрет подключения";
           
СостОткл = "Мини ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли

       
ИначеЕсли СостояниеОткл = "Завершение работы" Тогда
           
ДействиеЗавершения = "Завершение работы";
           
СостОткл = "Ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли
       
ИначеЕсли СостояниеОткл = "Завершение работы +" Тогда
           
ДействиеЗавершения = "Завершение работы";
           
СостОткл = "Мини ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли


       
ИначеЕсли СостояниеОткл = "Перезапуск ИБ" Тогда
           
ДействиеЗавершения = "Перезапуск ИБ";
           
СостОткл = "Ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли
       
ИначеЕсли СостояниеОткл = "Перезапуск ИБ +" Тогда
           
ДействиеЗавершения = "Перезапуск ИБ";
           
СостОткл = "Мини ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли

       
ИначеЕсли СостояниеОткл = "Завершение с подтверждением" Тогда
           
ДействиеЗавершения = "Завершение с подтверждением";
           
СостОткл = "Ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли
       
ИначеЕсли СостояниеОткл = "Завершение с подтверждением +" Тогда
           
ДействиеЗавершения = "Завершение с подтверждением";
           
СостОткл = "Мини ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = ВремяОткл;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение");
           
#КонецЕсли


       
ИначеЕсли СостояниеОткл = "Ожидание" Тогда
           
Время = ВремяОткл;
           
Время = Время - 0.25;
           
//Состояние ("Ожидание выхода из системы через" + ИзСекундВчасы(Время * 60), 100,"Ожидание выхода из системы через" + ИзСекундВчасы(Время * 60), БиблиотекаКартинок.ДлительнаяОперация48);
           
Если Время = 0 Тогда
               
СостОткл = "Предупреждение +";
            Иначе
               
СостОткл = "Ожидание";
            КонецЕсли;
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = Время;
           
Запись.Записать();
        ИначеЕсли
СостояниеОткл = "Предупреждение +" Тогда
           
СостОткл = "Мини ожидание";
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = 2;
           
Запись.Записать();
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
Предупреждение(Запись.Сообщение,15,"Предупреждение!");
           
#КонецЕсли
       
ИначеЕсли СостояниеОткл = "Мини ожидание" Тогда
           
Время = ВремяОткл;
           
Время = Время - 0.25;
            Если
Время * 60 < 60 Тогда
                Если
Время * 60 = 0 Тогда
                   
ПоказатьОповещениеПользователя("Внимание! Завершение работы!", ,"Система завершает работу...");
                Иначе
                   
ПоказатьОповещениеПользователя("Внимание! Завершение работы!", ,"Работа в системе будет завершена менее чем через " + Строка(Время * 60) + " секунд");
                КонецЕсли;
            КонецЕсли;
           
//Состояние ("Ожидание выхода из системы через" + ИзСекундВчасы(Время * 60), 100,"Ожидание выхода из системы через" + ИзСекундВчасы(Время * 60), БиблиотекаКартинок.ДлительнаяОперация48);
           
Если Время = 0 Тогда
               
СостОткл = "Отключение";
            Иначе
               
СостОткл = "Мини ожидание";
            КонецЕсли;
           
Запись.СостояниеОтключения = СостОткл;
           
Запись.ПаузаДоОтключения = Время;
           
Запись.Записать();
        ИначеЕсли
СостояниеОткл = "Отключение" Тогда
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
               
СостОткл = "Сеанс выключен";
               
Запись.СостояниеОтключения = СостОткл;
               
Запись.Записать();
                Если
ДействиеОткл = "Запрет подключения" Тогда
                   
Сообщить("1С Предприятие завершает работу через 15 секунд...", СтатусСообщения.ОченьВажное);
                   
Сообщить("Сохраните все данные!", СтатусСообщения.ОченьВажное);
                ИначеЕсли  
ДействиеОткл = "Завершение работы" Тогда
                   
Сообщить("1С Предприятие завершает работу через 15 секунд...", СтатусСообщения.ОченьВажное);
                   
Сообщить("Сохраните все данные!", СтатусСообщения.ОченьВажное);
                ИначеЕсли  
ДействиеОткл = "Перезапуск ИБ" Тогда
                   
Сообщить("1С Предприятие будет перезапущено через 15 секунд...", СтатусСообщения.ОченьВажное);
                   
Сообщить("Сохраните все данные!", СтатусСообщения.ОченьВажное);
                ИначеЕсли  
ДействиеОткл = "Завершение с подтверждением" Тогда
                   
Сообщить("Установлено завершение работы пользователей, пожалуйста, завершите работу!", СтатусСообщения.ОченьВажное);
                КонецЕсли;
           
#КонецЕсли
       
ИначеЕсли СостояниеОткл = "Сеанс выключен" Тогда
           
#Если Клиент Тогда
               
Сигнал();
               
Сигнал();
               
Сигнал();
                Если
ДействиеОткл = "Запрет подключения" Тогда
                   
СтопПроверкиОтключения();
                   
Предупреждение("Система завершила работу!. Нажмите ""ОК"" для выхода", 5,"Внимание!");
                   
ПрекратитьРаботуСистемы();
                ИначеЕсли  
ДействиеОткл = "Завершение работы" Тогда
                   
СтопПроверкиОтключения();
                   
Предупреждение("Система завершила работу!. Нажмите ""ОК"" для выхода", 5,"Внимание!");
                   
ПрекратитьРаботуСистемы();
                ИначеЕсли  
ДействиеОткл = "Перезапуск ИБ" Тогда
                   
СтопПроверкиОтключения();
                   
Предупреждение("Система завершила работу!. Нажмите ""ОК"" для выхода", 5,"Внимание!");
                   
ПрекратитьРаботуСистемы(Истина);
                ИначеЕсли  
ДействиеОткл = "Завершение с подтверждением" Тогда
                   
ЗавершитьРаботуСистемы(Истина);
                   
СостояниеОткл = "Мини ожидание";
                   
СостОткл = "Мини ожидание";
                   
Запись.СостояниеОтключения = "Мини ожидание";
                   
Запись.БыстроеОтключение = Истина;
                   
Запись.ПаузаДоОтключения = 2;
                   
Запись.Отключить = Истина;
                   
Запись.Записать();
                КонецЕсли;
           
#КонецЕсли

       
ИначеЕсли СостояниеОткл = "Работа разрешена" Тогда
                   
Запись.СостояниеОтключения = "Ложь";
                   
Запись.БыстроеОтключение = Ложь;
                   
Запись.Отключить = Ложь;
                   
Запись.ЗапретПодключения = Ложь;
                   
Запись.ДействиеОтключения = "Ложь";
                   
Запись.Записать();
                   
Предупреждение("Работа в системе разрешена, можно продолжать работу!",15,"Предупреждение!");
   
//  КонецЕсли;
   
КонецЕсли;
       
//-----------------------------------------
       
Если Запись.ОбменСообщений <> "" Тогда
           
//ПоказатьОповещениеПользователя("Новое сообщение", ,Запись.ОбменСообщений);
           
Если Найти(Запись.ОбменСообщений, "#sys") = 0 Тогда
               
Сообщить(Запись.ОбменСообщений, СтатусСообщения.Информация);
               
Запись.ОбменСообщений = "";
               
Запись.Записать();
            Иначе
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
// ЦиклическийВызов()

// Процедура контроля отключения.
//
Процедура СтопПроверкиОтключения() Экспорт
   
ОтклПользователей = РегистрыСведений.доОтключениеПользователей;
   
Отбор = Новый Структура("Пользователь");
   
Отбор.Пользователь = УправлениеПользователями.ОпределитьТекущегоПользователя();
   
ВыборкаРегистра = ОтклПользователей.Выбрать(Отбор);
    Пока
ВыборкаРегистра.Следующий() Цикл
       
Запись = ВыборкаРегистра.ПолучитьМенеджерЗаписи();
       
Запись.Отключить = Ложь;
        Если
ВыборкаРегистра.СостояниеОтключения = "Предупреждение" ИЛИ ВыборкаРегистра.СостояниеОтключения = "Предупреждение +" ИЛИ ВыборкаРегистра.СостояниеОтключения = "Ожидание" Тогда
           
Запись.ДатаВремяПуска = ТекущаяДата();
           
Запись.СостояниеОтключения = "Неактивен";
        Иначе
           
Запись.СостояниеОтключения = "Неактивен";
        КонецЕсли;
       
Запись.Записать();
    КонецЦикла;
КонецПроцедуры
// СтопПроверкиОтключения()


Модуль обычного приложения (модуль управляемого приложения)

Процедура ПередНачаломРаботыСистемы(Отказ)
   
//какие - то вызовы
   
СтартПроверкиОтключения(Отказ);
КонецПроцедуры

Процедура
ПриЗавершенииРаботыСистемы()
   
//какие - то вызовы
   
СтопПроверкиОтключения();
КонецПроцедуры

Файлы обработки:

-



Back to top