Виртуальная клавиатура поиска по таблице 1Сv8.2


Для тонкого клиента. Обработка сделана для сенсорного экрана. Осуществляет ввод строки и поиск по строке в исходной таблице для последующего выделения нужной строки. Легко может быть переделана под конкретную задачу!

Для работы необходимо добавить её в конфигурацию и сделать вызов:

&НаКлиенте

Процедура НайтиПоТаблицеТовары(Команда)

ФормаПоиска = ПолучитьФорму("Обработка.ВиртуальнаяКлавиатура.Форма.Форма",,ЭтаФорма);//Элементы.ТаблицаТовары);

ФормаПоиска.Открыть();

КонецПроцедуры

 

И в обработке оповещения добавить:

Если ИсточникВыбора.ИмяФормы = "Обработка.ВиртуальнаяКлавиатура.Форма.Форма" Тогда

Если ТипЗнч(ВыбранноеЗначение) = Тип("СправочникСсылка.Номенклатура") Тогда

ПараметрыОтбора = Новый Структура;

ПараметрыОтбора.Вставить("Номенклатура", ВыбранноеЗначение);

НайденныеСтроки = ТаблицаТовары.НайтиСтроки(ПараметрыОтбора);

Если НайденныеСтроки.Количество()>0 Тогда

Элементы.ТаблицаТовары.ТекущаяСтрока = НайденныеСтроки[0].ПолучитьИдентификатор();

КонецЕсли;

КонецЕсли;

КонецЕсли;

Файлы обработки:

-



Back to top