7 печатных форм Счет-Фактур для использования в 2012 году


19 июля 2011 года Президент подписал закон № 245-ФЗ. Среди прочего, закон наконец-то вводит понятие «корректировочный счет-фактура», т.е. счет-фактура, составляемый при изменении цены реализации, если такое изменение произошло уже после отгрузки продукции (товаров) или выполнения работ (услуг).  Вот взял и адаптировал под действующую "Управление Торговлей, ред.10.3" печатные формы счет-фактур, что были под рукой.
24.01.2012 добавил новую печатную форму по постановлению Правительства Российской Федерации от 26 декабря 2011 г. № 1137

1. Постарался "отвязать" от общих модулей, путем переноса функций в модуль обработки.

2. Вставил проверку на существование реквизитов "НаАванс", "УдаленНаАванс" типа:      

МетаданныеДокумента = СсылкаНаОбъект.Метаданные();
     Если ЕстьРеквизитДокумента("НаАванс", МетаданныеДокумента) Тогда
            Если СсылкаНаОбъект.НаАванс = Истина Тогда
                   Возврат Неопределено;
            КонецЕсли;
      ИначеЕсли ЕстьРеквизитДокумента("УдалитьНаАванс", МетаданныеДокумента) Тогда
             Если СсылкаНаОбъект.УдалитьНаАванс = Истина Тогда
                    Возврат Неопределено;
      КонецЕсли;
  КонецЕсли;
3.  Поправил шапки печатных форм, шрифт, масштаб, ориентацию везьде сделал ТРАДИЦИОННОЙ :) 
4.  Авторегистрация.

Файлы обработки:

-



Back to top