как преобразовать запрос на языке 1С в запрос SQL-сервера? #318521


#0 by shredder2003
я запустил Enterprise Integrator, выбрал конструктор запроса, сделал запрос: ВЫБРАТЬ ПЕРВЫЕ 10    Банки.Код,    Банки.НаименованиеПолное ИЗ и я не пойму, КАК его преобразовать в запрос, который выполняет MS SQL Server? пожалуйста, подскажите, а то уж я думаю, то ли лыжи не едут...
#1 by shredder2003
версия 1C 8.0.13
#2 by sapphire
хм... а зачем?! Он также шустро отработает как ив SQL
#3 by selenat
не пробовал, но вот
#4 by КонецЦикла
профайлер фпомощь...
#5 by mikecool
видимо встроит его в какую-нить приблуду, написанную на каком-нить языке...
#6 by sapphire
конечно, лыжи виноваты, кто же еще. Читай внимательно доку к EI. Я использовал StrBaseSQL для получения имен таблиц объектов
#7 by Ц_У
Select top 10 (Банки.Код,Банки.НаименованиеПолное) from Справочник.Банки as Банки :)
#8 by КонецЦикла
:) Server: Msg 170, Level 15, State 1, Line 1 Line 1: Incorrect syntax near ','. От зараза, а когда скобки убираешь грит: Server: Msg 208, Level 16, State 1, Line 1 Invalid object name 'Справочник.Банки'.
#9 by mikecool
а скобки зачем после  top 10 ?
#10 by sapphire
Я увидел шубу на тебе, это был песец(c)
#11 by КонецЦикла
Так пишут в учебных центрах :)
#12 by shredder2003
StrBaseSQL - что это такое?
Tags:


Ответить:

Back to top