SSL и Яндекс/Mail/Rambler и прочая почта #720802


#0 by Asmody
Если у вас проблемы с SSL и почтой, то самый верный ответ — "переходите на 8.3, там это реализовано". Вопрос обсуждается в этих ветках: За новые ветки по этой теме будет бан за вандализм.
#1 by minsk1s
не на всех версиях 8.3. 8.3.4.465 - SSL НЕ РАБОТАЕТ !!! 8.3.5.1119 - SSL РАБОТАЕТ !!! сегодня пол дня мучил)
#2 by r2d24
прочел статьи, так и не понял. Надо ли устанавливать какие нибудь дополнительные компоненты? И может ли кто выложить образец кода, который отправляется по почте.
#3 by abuca
Кажется проблему с почтой Яндекса и Мэйла решил и для 8.2 и для 8.3. Для отправки почты 8.2 и 8.3 используем SMTP: yandex: порт: 587, mail.ru: порт:587 Для 8.3 прописать: Профиль.ИспользоватьSSLSMTP = ИспользоватьSSLSMTP; Хотя 8.2 и без этого подключилось на указанном порту. Для получения почты 8.2 только IMAP, 8.3 IMAP или POP3: порты: Yandex, Mail.ru: IMAP 993 POP3 995   сервер: логин в любых случаях в виде: login@mail.ru Login@yandex.ru Проверьте, обязательно подтвердите или опровергните. Ваша помощь поможет всем. написал простенькую обработку которая помогла. Если модераторы разрешат, выложу ссылку на обменник. Работает в 8.2 и 8.3 (режим запуска "Обычное приложение") Не баньте опять, я "не рыдаю по яндексу и мэйлу", я решаю проблему, кстати наболевшую у многих. Перестали отправляться счета, прайсы и т.д. не только у меня одного. Если что-то нарушил, дайте предупреждение, а не трольте. Только начали решать проблему - нате бан!
#4 by abuca
Сорри напутал: Для 8.3 прописать: Профиль.ИспользоватьSSLSMTP = Истина;
#5 by abuca
Вот код: Присваиваемые реквизиты сами пропишете на форме. Если обработка выполнилась и не выдала ошибок - все ок.
#6 by EvgeniuXP
да не надо там это писать, работает там всё без SSL-а.
#7 by vlandev
майл-ру не пускает без SSL/TLS по попе с тех пор , как были выложены в инет списки логинов/паролей их клиентов. Это надо было сделать еще десять лет назад что бы открытым текстом логины и пароли через сеть не ходили , ну хорошо что хоть счас прочухали.
#8 by EvgeniuXP
у меня пускает - в восьмере (8.3.5.1186) - тестил сам на этой неделе (маил ру и яндекс.ру). В 7.7 не пускает, при этом телнет показывает что порты доступны 110 и 25-ый.
#9 by Arh01
Почта на qip.ru работает без всяких ssl
#10 by GreyK
Зачем нужно переводить конфу на 8.3, если stunnel это делает для всех программ, использующих почту без поддержки SSL?
#11 by EvgeniuXP
чтоб костыли не ставить :)
#12 by abuca
К чему полемика? Я указал порты. Проверьте. Подключается по этим портам с этими настройками. В 8.2 УТ 10.3 вчера по IMAPу получил прайс с Яндекс-почты в самописной обработке. ССЛ РАБОТАЕТ в 8.2. Обновите до 8.2.19.1хх не помню точно. Не проверил пока отправку на порт 587. Этот работает без ССЛ. Он не описан ни на яндексе ни на мэйле. Но, подключение на него проходит. Вызвало сомнение: второпях перенастроил отправку счетов почтой. Подключение успешно прошло, Но отправку прервал сервер на этапе отправки сообщения. Надо проверить! У кого есть возможность? Я до понедельника не могу, на даче.
#13 by vlandev
Странно , у мну майлру при попытке получить письмо по незащищенному протоколу пишет: -ERR POP3 is available only with SSL or TLS connection enabled
#14 by abuca
Читайте Внимательно! Получать по IMAP!!! В приведенном коде ищем строчку: ИспользоватьSSLIMAP  должно быть Истина. Почта.Подключиться(Профиль,Протокол) протокол должен быть: Протокол = ПротоколИнтернетПочты.IMAP в 8.2.19.1хх уже есть получение с использованием ССЛ по IMAP
#15 by abuca
Читайте в справке метод Подключиться. Если опустить 2й параметр, протокол, подключение произойдет по POP3. Поэтому вторым параметром обязательно ставим протокол Почта.Подключиться(Профиль,ПротоколИнтернетПочты.IMAP);
#16 by EvgeniuXP
скока гемора :) не было этого.
#17 by abuca
Подвожу итог: на данном этапе на платформе 1С:Предприятие 8.2 (8.2.19.106) получение почты происходит через IMAP. Проверено. Не обсуждается. У кого не работает - читайте все внимательно еще раз. Отправка почты не происходит, т.к. в данной версии платформы не предусмотрен метод:  ИспользоватьSSLSMTP. Поэтому на порт 465 происходит прерывание по таймауту, а порт 587 возвращает ошибку с требованием использовать SSL. на платформе 1С:Предприятие 8.3 (8.3.4.496) и отправка (порт 465) и получение см. выше работает хорошо. Кто не хочет обновлять до 8.3 ждем выхода очередной 8.2... Ветку, думаю, пока не закрывайте. В ближайшее время проверю новые релизы платформы, отпишусь.
#18 by bug16
а кто подскажет как быть с мобильным приложением? свойство ИспользоватьSSLSMTP не работает в мобильно приложении... Доступность: Тонкий клиент, сервер, толстый клиент, внешнее соединение. всё таки может кто знает бесплатный почтовик без SSL?
#19 by КонецЦикла
qip.ru, km.ru
#20 by bug16
блин ошибка Параметр команды не реализован (SMTP error code 504) профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
#21 by КонецЦикла
Обязательная аутентификация... и проверь правильные ли параметры, все работает Вне впадлу было все переделывать и для служ. целей стал его юзать
#22 by bug16
а как поставить обязательную аунтефикацию, чет не могу найти параметра... про это речь профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login; ?
#23 by КонецЦикла
Ну да видимо, = Истина
#24 by bug16
неа.. не получается, SMTP error code 504, 5.5.0 Authenticate first
#25 by КонецЦикла
Пароль проверь, логин Если совсем плохо - беги
#26 by bug16
>>и для служ. целей стал его юзать а можешь свои настройки показать?
#27 by КонецЦикла
Чтобы ты мне обмены попортил?
#28 by bug16
ну логин с паролем убери :)
#29 by abuca
дай весь код с момента инициализации до команды Подключить. Попробуй прописать POP3, опыт подсказывает, что это необходимо. Прочитай про метод Подключить(Профиль,ПротоколПодключения) Там написано, что по умолчанию  протокол подключения POP3. Т.е. по умолчанию на отправку используется тот же логин и пароль что были прописаны в профиле на POP3. Вот тебе и ошибка "Требуется сперва авторизоваться", POP3-то ты не заполнил ни логин, ни пароль.   Как вариант, попробуй прописать в метод Подключить вторым параметром ПротоколИнтернетПочты.SMTP.
#30 by bug16
спасибо, всё получилось на qipЕ... pop не указывал
#31 by John83
кто-нить подскажет, на какой почте работает отправка без обновления до 8.3?
#32 by BigShmax
На двух серверах с яндекс почтой помирились по 10 минут на сервер, никаких проблем  8.2.15.301   а вот на третьем слать надо с маил ру  бьюсь не побеждается.  Ошибка :  econ-enisey@mail.ru. {ОбщийМодуль.УправлениеЭлектроннойПочтой.Модуль(1115)}: Ошибка при вызове метода контекста (Подключиться): Can not authenticate to SMTP server: 535 5.7.8 r9sm1523516l
#33 by BigShmax
в логах вижу вот что 2014.09.30 16:05:38 LOG5[2780]: Service [gmail-smtp] accepted connection from 127.0.0.1:60228 2014.09.30 16:05:38 LOG5[2780]: s_connect: connected 173.194.71.109:465 2014.09.30 16:05:38 LOG5[2780]: Service [gmail-smtp] connected remote server from 192.168.0.250:60229 2014.09.30 16:05:39 LOG5[2780]: Connection closed: 73 byte(s) sent to SSL, 481 byte(s) sent to socket
#34 by John83
каким образом с яндексом помирились?
#35 by BigShmax
Всё нормально помирился, сам затупил по полной.  операционка скрываола разрешение  и я правил файл stunnel.config.config  а тунель ессно работал на нормальном и ломился на гмейл.
#36 by Arh01
qip.ru
#37 by John83
спасибо за отклик получилось на gmail прикрутить, но хотят все же на mail - завтра буду ковырять
#38 by liam neeson
Из дополнений к описанию КА 1.1.52 : "На форму Подключение справочника "Учетные записи электронной почты" добавлены реквизиты "Использовать защищенную версию протокола SMTP" и "Использовать защищенную версию протокола POP3". При установке этих реквизитов предоставляется возможность подключаться к почтовым серверам через безопасное соединение (SSL). Реквизиты доступны при использовании версии платформы не ниже 8.3.1." Так-что все костыли можно выкидывать.
#39 by nlv-lara
Кто-нибудь решил проблему с отправкой почты на платформе 8.2.19.*** через stunnel (yandex) или другими способами? Почта приходит без проблем даже через РОР3
#40 by arishkaKlimova
Вчера один из ящиков перестал получать письма. Исходящие уходят нормально, но при проверки входящих пишет, что писем новых нет. Всё! Ни ошибок, ни чего. Установил Thunderbird - там вся почта приходит нормально. Не понимаю, что могло произойти, чтобы так случилось. Почта на яндексе. Остальные ящики работают нормально. Может быть есть какие-нибудь типичные проблемы? Или вдруг кто сталкивался с подобной? Кто что думает?
Тэги:
Ответить:
Комментарии доступны только авторизированным пользователям

В этой группе 1С

Back to top