Тонкий клиент и толстый клиент: обращение к общим модулям...? #773468


#0 by Обработка
У менять есть почти во всех справочниках в модуле менеджера такое. ...... ...... Так вот в тонком клиенте все работает норм. А вот запуск в толстом клиенте ругается на отсутсвие функции ТекущийЯзыкРусский... Почему, кто чем посоветует???
#1 by Обработка
+ В общем модуле функция выглядит так:
#2 by Обработка
И на самом общем модуле стоит галочки: Клиент Сервер Врешнеее соединение
#3 by Mankubus
&НаСервере -- это не нужно в общих модулях
#4 by b_ru
Так ведь галочки "толстый клиент" на модуле не стоит, вот он и ругается.
#5 by Обработка
там нет такой галочки... Их всего три в свойствах модулей.
#6 by b_ru
То что она не показывается, не значит что ее нет :) Включи режим совместимости конфы - появится. Ну или не насилуй тру^W толстого клиента.
#7 by Nuobu
Там есть галочка "Клиент (Обычное приложение)"
#8 by Обработка
Режим совместимости стоит 8.3.3. Сама конфа написаная с нуля на 1с.8.3 в режиме такси и по интерфейсу совместим с 8.2
#9 by Обработка
Обычно в базу я и все юзеры ходят в тонком клиенте. Но при отладке иногда запускается в толстом...
#10 by Обработка
Не прав.
#11 by b_ru
методом тыка выяснил, что галочка появляется, если основной режим запуска установлен в "обычное приложение".
#12 by Обработка
Путаешь. Свойство модуля в конфе там всего три пункта.
#13 by Обработка
Увидел. Но это ничего не изменяет. У меня же УФ
#14 by ДенисЧ
основной режим запуска влияет только на то, как она из конфигшуратора по Ф5 запускаться будет
#15 by Pistol
Четыре
#16 by Обработка
Уже понял и увидел из . Но у меня Управлемое приложение.
#17 by b_ru
Толстый/тонкий клиент и Управляемые/неуправляемые формы - это ортогональные понятия. (Правда, в 1с нет неуправляемых форм в тонком клиенте, но это нюансы).
#18 by Обработка
Не стоит тут филосовствоаать. Мне важно решить свою задачу. Как мне поправить самописку чтоб это у меня не возникало. А то уже почти год меня это тревожит . Я не решал эту проблему потому что особо и не запускаю под толстым клиентом. Но вот задался целю код подпраавить.
#19 by Shrek_yar
Добавь #Если ТонкийКлиент
#20 by Nuobu
#Если Клиент // это толстый клиент
#21 by Shrek_yar
?? поясни
#22 by Nuobu
Что пояснять?
#23 by Обработка
Спасибо за советы. Я смогу разделить и сделать разные обработчики от отлстого и тонкого клиента. Но я так и не пойму в чем моя ошибка использования конечной функции. Как мне переписать обращение?
#24 by Cyberhawk
Поищи в этом модуле инструкцию препроцессора "ТонкийКлиент"
#25 by Обработка
В модуле прописал. Условие отрабатывается. Но мне же в ветку иначе надо опять писать код. И я все равно должен обращатся в общий модуль. Или куда мне эту процедуру разместить. Задача решается если я эту функцию перетащу в модуль менеджера справочника. Но тогда мне нужно будет во всех справочника перенести эту фукнкцию в модуля менеджеров каждого справочника. Это не есть решение проблемы.
#26 by Trucker
Зайди в параметры конфигуратара и выстави на закладке Общие Управляемое приложение и обычное приложение. Появится галка Клиент(обычное приложение) у общего модуля.
#27 by Обработка
#Если ТонкийКлиент Тогда         Если НЕ ОбщегоНазначенияКлиентСервер.ТекущийЯзыкРусский Тогда КонецПроцедуры
#28 by Feunoir
Я таки не понял ТС из общего модуля директиву &НаСервере уже убрал или пока нет?
#29 by Обработка
Пробовал убрать сразу ошибку  кажет.
#30 by Обработка
+ Потому что в нем есть обращение на сервер.- ПараметрыСеанса
#31 by Обработка
А модуль по умоланию и серверный и клиент и даже внешнее соеднение
#32 by Feunoir
А параметры сеанса в тонком клиенте недоступны. Поэтому тебе нужно вынести эту процедуру в модуль, у которого стоят галки Сервер и Вызов сервера. Чтобы не переписывать все места где это встречаются нужно сделать заглушку-прокси.
#33 by Обработка
У меня как раз ошибка вылетает на толстом клиенте. И еще я в том модуле пробовал включать Вызов сервера не помогает ни как.
#34 by Feunoir
У меня стойкое подозрение что толстый клиент криво компилит модуль, который по разному присутствует в разных контекстах. Например если при первом вызове к нему обращаются из клиентского контекста, то он его компилит без функции ТекущийЯзыкРусский, а когда потом вызывают в серверном контексте - забывает перекомпилировать. Или другое сумасшедшее предположение, что в толстом клиенте модуль менеджера работает в клиентском контексте. И вызывает модуль ОбщегоНазначенияКлиентСервер тоже в клиентском контексте. В результате получается болт.
#35 by Обработка
Я все ждал такого рода ответ или хотя бы рассуждение. Спасибо. Сам думаю, оставить разбирать эту ситуацию и просто в толстом клиенте исключить обращение как я выше это попробовал. При этом в толстом клиенте отображение  представления нужных элементов справочников не на русском языке не будет выполнен. Это в принципе не критично, поскольку все сидят на тонком клиенте. Даже мне нет особой надобности ходить в толстом клиенте. Но хотел бы для себя и для кургозора понять в чем глюк? Или я криво реализовал или это глюк платформы.
#36 by Drac0
В модуле ОбщегоНазначенияКлиентСервер должно быть установлены директивы: "#Если &ТонкийКлиент ИЛИ &Сервер", но нету &ТолстыйКлиентУправляемоеПриложение
#37 by Обработка
Не переварил...
#38 by Drac0
Тебе ссылку в давали.
#39 by Обработка
Читал и не раз. Но там нет решения.
#40 by Drac0
В кикие директивы препроцессора заключена твоя функция?
#41 by Обработка
Пока просто так: Возврат НЕ ЗначениеЗаполнено(ПараметрыСеанса.ТекущийЯзыкИнтерфейсаПрограммы) ИЛИ ПараметрыСеанса.ТекущийЯзыкИнтерфейсаПрограммы = ПредопределенноеЗначение("Справочник.Языки.Русский");          КонецФункции
#42 by Стальная Крыса
Что-то мудрите господа. для "толстого клиента" в общем модуле надо так: #Если НЕ ТолстыйКлиент Тогда &НаСервере #КонецЕсли Функция ... КонецФункции
#43 by Стальная Крыса
при совместном использовании "толстого" и "тонкого" вариантов такого геморроя не избежать  принципе
#44 by hhhh
поставь галки Толстый клиент, Сервер и Вызов сервера слово &НаСервере убери
#45 by Обработка
Уже и сам догадался #Если ТолстыйКлиентУправляемоеПриложение Тогда      #Иначе     &НаСервере #КонецЕсли
#46 by Обработка
)))
#47 by Стальная Крыса
а почему не так #Если НЕ ТолстыйКлиентУправляемоеПриложение Тогда     &НаСервере #КонецЕсли
#48 by Обработка
ДА не суть все ясно. Всем спасибо!
#49 by Drac0
Чой-та бред. Сколько работал с самопиской на УФ, там так не извращались. Хотя работали на Тонком и Толстом одновременно. Плюс сейчас накидал демку - все работает отлично. Вызов из модуля менеджера функции общего модуля с &НаСервере.
#50 by Обработка
Не знаю что и как? Писал самописку на 1с8.3.3 Сейчас стоит 1с8.3.7 Режим совместимости стоит на 8.3.3
#51 by rozer76
это клево конечно но посмотри в типовых - там нет ОМ с галками одновременно и на клиенте и на сервере
#52 by rozer76
догадываешься почему? )
#53 by Обработка
Ошибаешься. Открыл типовую БП для казахстана вот даже само название говорит% АдминистрированиеКластераКлиентСервер АдресныйКлассификаторКлиентСервер БухгалтерскиеОтчетыКлиентСервер
#54 by Обработка
Это первые попавшиеся примеры у меня.
#55 by Обработка
И таких куча. Не открывайте мне америку. А то я подумал тоже.
#56 by rozer76
почитайте методики разработки на ИТС про проектирование ОМ...
Тэги:
Ответить:
Комментарии доступны только авторизированным пользователям

В этой группе 1С

Back to top