v7: подсчитать количество записей в Подчиненном справочнике #195216


#0 by yaa
Хотел подсчитать количество записей в Подчиненном справочнике "ПосетилиСтоловую" при закрытии (на случай удаления из него), чтобы изменить соответствующий реквизит КолЧеловек в основном справочнике "Меню", но не очень-то получилось. Подскажите куда что добавить... Прошу помощи...
#1 by Таня
а для этого не лучше ли использовать забалансовый счет или регистр?
#2 by Прохожий
СпрПосетилиСтол.Владелец Только какого элемента? Чегой-то хитрое написал. Слушай .
#3 by Ёпрст2
Вы всё еще кодите? Не лучше ли выпить?
#4 by yaa
Может кто поможет исправить существующие строки... Куда каких Владельцев приписать и т.п... Заранее благодарен!
#5 by фывапр
Если ПометкаУдаления=0 Тогда а это пометка удаления чего?
#6 by Морозов Александр
Я так и не понял что куда пишется...
#7 by фывапр
#8 by ВторНик
может еще раз, и по русски?
#9 by yaa
Надо подсчитать количество непомеченных на удаление записей в подчиненном справочнике ПосетилиСтоловую и занести это число (НеУдал) в реквизит КолЧеловек в основном справочнике Меню. Прекрасно понимаю, что имеющийся код неправильный, поэтому и прошу помощи... Знал бы не спрашивал... Если нет желания помочь, то не стоит высмеивать (хотя и вопрос может быть совсем детский), по-моему форум не для этого. Надеюсь на помощь поистине отзывчивых людей.   Процедура ПриЗакрытии КонецПроцедуры
#11 by ЗЫ5
Этим проблему не решить!!!!!
#12 by КонецЦикла
Сделай тогда в процедуре ПриЗаписи
#13 by yaa
это надо на случай, если при повторных просмотрах подчиненного справочника обнаружили, что туда лишнее что то ввели, и решили эти записи удалить
#14 by КонецЦикла
Не очень понятно, но попробуй то что выше
#15 by zbv
глаза режет. ПриЗакрытии - это в каком справочнике?
#16 by yaa
В подчиненном!
#17 by yaa
В подчиненном
#18 by КонецЦикла
Тю... Во владельце наверное?
#19 by yaa
Не-а, в подчиненном
#20 by КонецЦикла
ну ладно
#21 by yaa
Спасибо! Позже попробую!
#22 by BARS_2
Если это из подчиненного открывается то разве так правильно? ?
#24 by BARS_2
Да и какой смысл тогда выбирать пользователю СПрМеню, если по правильному получается СпрМеню.найтиЭлемент(ТекущийЭлемент.Владелец)
#25 by BARS_2
о!
#26 by КонецЦикла
Так все тоже самое... только до конца написано, автор просто не понял
#27 by yaa
{Справочник.ПосетилиСтоловую.ФормаСписка.ФормаСписка.Модуль}: Не выбран элемент!
#28 by yaa
{Справочник.ПосетилиСтоловую.ФормаСписка.ФормаСписка.Модуль}: Не выбран элемент!
#29 by zbv
Блин точняк. Надо как в Эту строку Только вот пихать эту процедуру в формусписка... Как то неочень.
Tags:


Ответить:

Back to top