v7: разница между #Записать Провести? Закрыть и Записать() Провести() Форма.Закрыть( #633692


#0 by Mashinist
Ситуация такая Из формы документа А открывается другой документ Б через ОткрытьФорму(...) В открытом документе если на кнопке ОК написано #Записать Провести? Закрыть, то в форме документа А после закрытия документа Б возникает событие ОбработкаПодбора Но если заменить кнопку на вызов своих процедур (т.к. нужно контролировать процесс), то это событие не возникает. А т.к. документ А заполняется по документам Б, то все получается плохо... А было хорошо, когда было #Записать Провести? Закрыть Может можно как-то вызвать ОбработкаПодбора как-то...
#1 by Fragster
переходите на v8, там это реализовано
#2 by zak555
не хорчешь наживать на ОК ?
#3 by zak555
Парам.Форма.СрокаДействияФормы = "Записать Провести";
#4 by Mashinist
Хочу контролировать процесс Записи и Проведения Т.е. на на кнопку ОК повесил процедуру где выполняются по сути те же действия А результат получается разный...
#5 by Classic
В семерке функция Записать не вызывает обработку функции ПриЗаписи. Она просто пишет. Это насколько я помню
#6 by Mashinist
Что за СрокаДействияФормы ? что-то я в СП такого не нахожу
#7 by Mashinist
Ага.. кажется нашел что такое СтрокаДействийФормы Сейчас попробую
#8 by Cthulhu
: да. но не трагедия. "ПриЗаписи; Если СтатусВозврата=1 Тогда Записать; Провести; КонецЕсли;"
#9 by Mashinist
Спасибо за наводку В какой-то мере помогло... Проблема осталась с кнопкой "Провести" Когда пишешь в тексте СтрокаДействийФормы ="Провести" то дальнейший код не отрабатывает Т.е. я раньше писал так Провести В Если не попадает вообще
#10 by Cthulhu
: вешай в строку действий процедуру, которая и проводит, и дальше что надо делает.
#11 by Ork
Вообще говоря Провести тоже может возвращать результат. Вот его и нужно проверять. А уж если хочется проверить именно проведенность - тогда через ТекущийДокумент.
#12 by ЧеловекДуши
Вечер нечегонепонимаю :)
#13 by Mashinist
значит суть такова МояПроцедураПровести СтрокаДействийФормы ="Провести" ... КонецПроцедуры все проходит по порядку, только документ реально проводится после окончания процедуры Но ситуация до конца не решается Было три кнопки ОК (#Записать Провести? Закрыть), Провести(#Провести) и Закрыть(#Закрыть) Вот так все было хорошо Нажимаем ОК, документ проводится, закрывается и вызывается ОбработкаПодбора в вызываемом документе Нажимаем Провести документ проводится. Нажимаем Закрыть документ закрывается и вызывается ОбработкаПодбора в вызываемом документе Теперь я на кнопку Провести вешаю свою процедуру, где пишу МояПроцедураПровести СтрокаДействийФормы ="Провести" КонецПроцедуры Кнопка Закрыть(#Закрыть) так и осталась Нажимаю Провести документ проводится. Нажимаем Закрыть документ закрывается, но вот бработкаПодбора в вызываемом документе НЕ ОТРАБАТЫВАЕТ!!!
#14 by ЧеловекДуши
При чем тут форма одного документа вызываемая из другого и при этом во втором вызывается еще и третья :)
#15 by ЧеловекДуши
Зачем тебе, что бы отрабатывала обработка подбора во втором документе, если пользователь интерактивно работает только с первым, и понятие не имеет об втором?
#16 by Mashinist
Короче Тема закрыта Разобрался Все в том, что не вызывалось у меня Вот эта штука и дергает вызывающий документ забывать стал 7-ку "В 8-ке это реализовано " :-)
#17 by Cthulhu
мнда...
#18 by KRV
букву "а" пропустил? )))
Тэги: 1С 7.7 и ранее
Ответить:
Комментарии доступны только авторизированным пользователям

В этой группе 1С

Back to top